Disconnessione Philips XXXpfl con DLNA dopo 20 min

Collegando un tv Philips serie PFL in rete, si è riscontrato un problema di disconnessione, durante la visualizzazione di filmati archiviati, su di un server dlna fatto in casa casa .L’errore si presentava ogni 20 minuti di visualizzazione di filmato, la TV in se, si disconnetteva dalla rete e non riusciva ad agganciare il segnale del server dlna. Ho cercato invano sul forum di supporto philips e vi erano pagine interminabili di discussioni con lo stesso problema di disconnessione dai 20-30 min ma nulla da fare, alcune risoluzioni trovate sul forum erano estreme … dal cambio router al cambio televisore, roba da matti ! Dopo giorni di ricerche studiando l’intera infrastruttura di un server dlna sono partito dal collegamento che avveniva tra router e server che era tramite l’Universal Plug and Play (UPnP) come protocollo di rete, infatti ho riscontrato che il mio router della tp link TD-W8960N V4 aveva dei bug upnp sul firmware , trovata la soluzione sui change log del firmare ho effettuato l’aggiornamento con firmware della v4

Firmware Version:1.1.1 Build 140228 Rel.43206

ho effettuato il download del firmware dal sito ufficiale della tp link con un cavo di rete collegato al mio notebook ho effettuato l’upgrade firmware del router.Riporto di  seguito inserisco la tabella dei bug fix per questa versione di firmare

Modifiche e correzioni di bug
  1. Fixed bonjour issue.
  2. The web management interface will be blocked for 10 miuntes after trying wrong username or password for 5 times.
  3. Add MTU settings in IPOE and IPOA.
  4. Fixed UPNP issue.
  5. Fixed the issue that SIP ALG function doesn’t take effect until it reboot.

il philips xxxpfl ora funziona bene e tramite il collegamento lan non ho avuto più nessuna disconnessione.

*alcuni dlna server (rygel) consigliano di disattivare IGMP sul router